import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "01(?=\\.jpg)(.*)(\\d{2}).jpg";
final String string = " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_55.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_56.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_57.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_58.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_59.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_60.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_61.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_62.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_63.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_64.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_65.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_66.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_67.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_68.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_69.jpg\" media-type=\"image/jpeg\"/>\n"
+ " <item id=\"P2_0102_01.jpg\" href=\"images/01_02/P2_0102_70.jpg\" media-type=\"image/jpeg\"/>";
final String subst = "\\2\\1\\2.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}