const regex = /01(?=\.jpg)(.*)(\d{2}).jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('01(?=\\.jpg)(.*)(\\d{2}).jpg', 'g')
const str = ` <item id="P2_0102_01.jpg" href="images/01_02/P2_0102_55.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_56.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_57.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_58.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_59.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_60.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_61.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_62.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_63.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_64.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_65.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_66.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_67.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_68.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_69.jpg" media-type="image/jpeg"/>
<item id="P2_0102_01.jpg" href="images/01_02/P2_0102_70.jpg" media-type="image/jpeg"/>`;
const subst = `\2\1\2.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);