using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"234(\d{3})(\d{7})";
string input = @"2348064356853,2347065478934,2348167456845,2347123454680";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}