re = /234(\d{3})(\d{7})/m
str = '2348064356853,2347065478934,2348167456845,2347123454680'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end