$re = '/234(\d{3})(\d{7})/m';
$str = '2348064356853,2347065478934,2348167456845,2347123454680';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);