import re
regex = re.compile(r"234(\d{3})(\d{7})", flags=re.MULTILINE)
test_str = "2348064356853,2347065478934,2348167456845,2347123454680"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")