use strict;
my $str = '19097147835';
my $regex = qr/^1(?=\d{10})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";