using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<w:p[^>]+>(?:(?!<\/wp>).)+?<\/w:p>)";
string input = @"<w:p>
Some Other XML
<w:p someatribute=""something"">
HERE
</w:p>
Some Other XML
</w:p>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}