re = /(<w:p[^>]+>(?:(?!<\/wp>).)+?<\/w:p>)/
str = '<w:p>
Some Other XML
<w:p someatribute="something">
HERE
</w:p>
Some Other XML
</w:p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end