import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/|<)(\\w{4,})(?=>)|\\b(\\w{4,})";
final String string = "Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor\n"
+ "invidunt ut labore et dolore <strong>magna aliquyam erat</strong>, sed diam voluptua. \n"
+ "Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor \n"
+ "invidunt ut labore et dolore <strong>magna</strong> aliquyam erat, sed diam voluptua <lol>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}