# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\/|<)(\w{4,})(?=>)|\b(\w{4,})"
test_str = ("Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor\n"
"invidunt ut labore et dolore <strong>magna aliquyam erat</strong>, sed diam voluptua. \n"
"Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor \n"
"invidunt ut labore et dolore <strong>magna</strong> aliquyam erat, sed diam voluptua <lol>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.