$re = '/(?<=\/|<)(\w{4,})(?=>)|\b(\w{4,})/s';
$str = 'Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
invidunt ut labore et dolore <strong>magna aliquyam erat</strong>, sed diam voluptua.
Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
invidunt ut labore et dolore <strong>magna</strong> aliquyam erat, sed diam voluptua <lol>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;