#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)[2][0-9][0-9][0-9]\/[0-9][[0-9]\/"
Local $sString = "161 1 2015/12/17 14:52:08:44648 13668 38528 1 *** 15 5 CDF_ENTRY [Id=1] hook_MFCreateSourceResolver: Entering. " & @CRLF & _
"162 1 2015/12/17 14:52:08:44664 13668 38528 1 *** 15 5 CDF_ENTRY [Id=2] SourceResolverWrapper::FinalConstruct: Entering. " & @CRLF & _
"163 1 2015/12/17 14:52:08:44664 13668 38528 1 *** 20 5 CDF_ENTRY [Id=2] SourceResolverWrapper::FinalConstruct: Leaving. (hr=0x0) " & @CRLF & _
"164 1 2015/12/17 14:52:08:44665 13668 38528 1 *** 20 5 CDF_ENTRY [Id=1] hook_MFCreateSourceResolver: Leaving. (hr=0x0) " & @CRLF & _
"165 1 2015/12/17 14:52:08:44666 13668 38528 1 *** 15 5 CDF_ENTRY [Id=2] SourceResolverWrapper::BeginCreateObjectFromURL: Entering. "
Local $sSubst = "2016/01/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)