$re = '/[2][0-9][0-9][0-9]\/[0-9][[0-9]\//i';
$str = '161 1 2015/12/17 14:52:08:44648 13668 38528 1 *** 15 5 CDF_ENTRY [Id=1] hook_MFCreateSourceResolver: Entering.
162 1 2015/12/17 14:52:08:44664 13668 38528 1 *** 15 5 CDF_ENTRY [Id=2] SourceResolverWrapper::FinalConstruct: Entering.
163 1 2015/12/17 14:52:08:44664 13668 38528 1 *** 20 5 CDF_ENTRY [Id=2] SourceResolverWrapper::FinalConstruct: Leaving. (hr=0x0)
164 1 2015/12/17 14:52:08:44665 13668 38528 1 *** 20 5 CDF_ENTRY [Id=1] hook_MFCreateSourceResolver: Leaving. (hr=0x0)
165 1 2015/12/17 14:52:08:44666 13668 38528 1 *** 15 5 CDF_ENTRY [Id=2] SourceResolverWrapper::BeginCreateObjectFromURL: Entering. ';
$subst = "2016/01/";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;