import Foundation
let pattern = #"[2][0-9][0-9][0-9]\/[0-9][[0-9]\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
161 1 2015/12/17 14:52:08:44648 13668 38528 1 *** 15 5 CDF_ENTRY [Id=1] hook_MFCreateSourceResolver: Entering.
162 1 2015/12/17 14:52:08:44664 13668 38528 1 *** 15 5 CDF_ENTRY [Id=2] SourceResolverWrapper::FinalConstruct: Entering.
163 1 2015/12/17 14:52:08:44664 13668 38528 1 *** 20 5 CDF_ENTRY [Id=2] SourceResolverWrapper::FinalConstruct: Leaving. (hr=0x0)
164 1 2015/12/17 14:52:08:44665 13668 38528 1 *** 20 5 CDF_ENTRY [Id=1] hook_MFCreateSourceResolver: Leaving. (hr=0x0)
165 1 2015/12/17 14:52:08:44666 13668 38528 1 *** 15 5 CDF_ENTRY [Id=2] SourceResolverWrapper::BeginCreateObjectFromURL: Entering.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"2016/01/"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}