using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[""[^""]+"",\d\])";
string input = @"google.sbox.p50 && google.sbox.p50([""how to"",[[""how to tie a tie"",0],[""how to train your dragon 2 trailer"",0],[""how to do the cup song"",0],[""how to get a six pack in 3 minutes"",0],[""how to make a paper gun that shoots"",0],[""how to basic"",0],[""how to love lil wayne"",0],[""how to sing like your favorite artist"",0],[""how to be a heartbreaker marina and the diamonds"",0],[""how to tame a horse in minecraft"",0]],{""q"":""XJW--0IKH6sqOp0ME-x5B7b_5wY"",""j"":""5"",""k"":1}])";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}