package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\["[^"]+",\d\])`)
var str = `google.sbox.p50 && google.sbox.p50(["how to",[["how to tie a tie",0],["how to train your dragon 2 trailer",0],["how to do the cup song",0],["how to get a six pack in 3 minutes",0],["how to make a paper gun that shoots",0],["how to basic",0],["how to love lil wayne",0],["how to sing like your favorite artist",0],["how to be a heartbreaker marina and the diamonds",0],["how to tame a horse in minecraft",0]],{"q":"XJW--0IKH6sqOp0ME-x5B7b_5wY","j":"5","k":1}])`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}