import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[\"[^\"]+\",\\d\\])";
final String string = "google.sbox.p50 && google.sbox.p50([\"how to\",[[\"how to tie a tie\",0],[\"how to train your dragon 2 trailer\",0],[\"how to do the cup song\",0],[\"how to get a six pack in 3 minutes\",0],[\"how to make a paper gun that shoots\",0],[\"how to basic\",0],[\"how to love lil wayne\",0],[\"how to sing like your favorite artist\",0],[\"how to be a heartbreaker marina and the diamonds\",0],[\"how to tame a horse in minecraft\",0]],{\"q\":\"XJW--0IKH6sqOp0ME-x5B7b_5wY\",\"j\":\"5\",\"k\":1}])";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}