# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[\"[^\"]+\",\d\])"
test_str = "google.sbox.p50 && google.sbox.p50([\"how to\",[[\"how to tie a tie\",0],[\"how to train your dragon 2 trailer\",0],[\"how to do the cup song\",0],[\"how to get a six pack in 3 minutes\",0],[\"how to make a paper gun that shoots\",0],[\"how to basic\",0],[\"how to love lil wayne\",0],[\"how to sing like your favorite artist\",0],[\"how to be a heartbreaker marina and the diamonds\",0],[\"how to tame a horse in minecraft\",0]],{\"q\":\"XJW--0IKH6sqOp0ME-x5B7b_5wY\",\"j\":\"5\",\"k\":1}])"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.