#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "cast([^\n]+\n){2}.*datetime$"
Local $sString = "cast('"" & @CRLF & _
" + object.method()" & @CRLF & _
" + "' as datetime"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")