re = /cast([^\n]+\n){2}.*datetime$/
str = 'cast(\'"
+ object.method()
+ "\' as datetime'
# Print the match result
str.match(re) do |match|
puts match.to_s
end