$re = '/cast([^\n]+\n){2}.*datetime$/';
$str = 'cast(\'"
+ object.method()
+ "\' as datetime';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);