package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`cast([^\n]+\n){2}.*datetime$`)
var str = `cast('"
+ object.method()
+ "' as datetime`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}