using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Warning-\[ABC\] blablabla(\$|\n)*\s+\/path1.*";
string input = @"Warning-[ABC] blablabla
/path1/path2/path3/file";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}