re = /^Warning-\[ABC\] blablabla(\$|\n)*\s+\/path1.*/m
str = 'Warning-[ABC] blablabla
/path1/path2/path3/file'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end