const regex = /^Warning-\[ABC\] blablabla(\$|\n)*\s+\/path1.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Warning-\\[ABC\\] blablabla(\\$|\\n)*\\s+\\\/path1.*', 'gm')
const str = `Warning-[ABC] blablabla
/path1/path2/path3/file`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}