const regex = /\s*(?=\([^()]*\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?=\\([^()]*\\))', '')
const str = `Rosemary Hess (2018) (Germany) (all media)`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);