import Foundation
let pattern = #"\s*(?=\([^()]*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Rosemary Hess (2018) (Germany) (all media)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}