use strict;
my $str = 'Rosemary Hess (2018) (Germany) (all media)';
my $regex = qr/\s*(?=\([^()]*\))/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";