using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^A-ZА-ЯЁ\n]*[A-ZА-ЯЁ])(?=[^0-9\n]*[0-9])[-A-Z0-9А-ЯЁ.+~_!?*]+$";
string input = @"Latin.5
dfghjhgff
55678
.&&**&
tyrrrt66776
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}