const regex = /^(?=[^A-ZА-ЯЁ\n]*[A-ZА-ЯЁ])(?=[^0-9\n]*[0-9])[-A-Z0-9А-ЯЁ.+~_!?*]+$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^A-ZА-ЯЁ\\n]*[A-ZА-ЯЁ])(?=[^0-9\\n]*[0-9])[-A-Z0-9А-ЯЁ.+~_!?*]+$', 'igm')
const str = `Latin.5
dfghjhgff
55678
.&&**&
tyrrrt66776
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}