$re = '/^(?=[^A-ZА-ЯЁ\n]*[A-ZА-ЯЁ])(?=[^0-9\n]*[0-9])[-A-Z0-9А-ЯЁ.+~_!?*]+$/im';
$str = 'Latin.5
dfghjhgff
55678
.&&**&
tyrrrt66776
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);