import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^A-ZА-ЯЁ\\n]*[A-ZА-ЯЁ])(?=[^0-9\\n]*[0-9])[-A-Z0-9А-ЯЁ.+~_!?*]+$";
final String string = "Latin.5\n"
+ "dfghjhgff\n"
+ "55678\n"
+ ".&&**&\n"
+ "tyrrrt66776\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}