#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+(?:,\d+){9}[\r\n]*"
Local $sString = "6,0,0,0,0,0,259,2508,20,169" & @CRLF & _
"55,0,0,0,61,0,259,2508,20,169" & @CRLF & _
"91,0,0,0,60,0,259,2508,20,169" & @CRLF & _
"126,0,0,0,60,0,259,2508,20,169" & @CRLF & _
"162,0,0,0,60,0,259,2508,20,169" & @CRLF & _
"198,0,0,0,61,0,259,2508,20,169"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")