using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:,\d+){9}[\r\n]*";
string input = @"6,0,0,0,0,0,259,2508,20,169
55,0,0,0,61,0,259,2508,20,169
91,0,0,0,60,0,259,2508,20,169
126,0,0,0,60,0,259,2508,20,169
162,0,0,0,60,0,259,2508,20,169
198,0,0,0,61,0,259,2508,20,169";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}