import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:,\\d+){9}[\\r\\n]*";
final String string = "6,0,0,0,0,0,259,2508,20,169\n"
+ "55,0,0,0,61,0,259,2508,20,169\n"
+ "91,0,0,0,60,0,259,2508,20,169\n"
+ "126,0,0,0,60,0,259,2508,20,169\n"
+ "162,0,0,0,60,0,259,2508,20,169\n"
+ "198,0,0,0,61,0,259,2508,20,169";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}