using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[URL[^]]+\](?P<name>[^\[]+)\[\/URL\]";
string input = @"[URL=""http://google.com""]ANY THING[/URL]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}