re = /\[URL[^]]+\](?P<name>[^\[]+)\[\/URL\]/
str = '[URL="http://google.com"]ANY THING[/URL]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end