using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[URL(?:\=\""(?P<url>[^""]+)\"")?\](?P<name>[^\[]+)\[\/URL\]";
string input = @"[URL=""http://google.com""]ANY THING[/URL]
[URL]ANY THING[/URL]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}