$re = '/\[URL(?:\=\"(?P<url>[^"]+)\")?\](?P<name>[^\[]+)\[\/URL\]/';
$str = '[URL="http://google.com"]ANY THING[/URL]
[URL]ANY THING[/URL]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);