package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[URL(?:\=\"(?P<url>[^"]+)\")?\](?P<name>[^\[]+)\[\/URL\]`)
var str = `[URL="http://google.com"]ANY THING[/URL]
[URL]ANY THING[/URL]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}