using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*(ee|me)\w*(*SKIP)(*FAIL)|e";
string input = @"test <- c('met','meet','eel','elm'),";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}