$re = '/\w*(ee|me)\w*(*SKIP)(*FAIL)|e/';
$str = 'test <- c(\'met\',\'meet\',\'eel\',\'elm\'),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);