re = /\w*(ee|me)\w*(*SKIP)(*FAIL)|e/
str = 'test <- c(\'met\',\'meet\',\'eel\',\'elm\'),'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end