using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Last Power Event\.+\s(\w+)\s\S*\s(\d+\/\d+\/\d+\s+\d+\:\d+\d\:\d+)|(?:\s\S+\s)(\d+)\s(\S+)";
string input = @"Last Power Event............. Blackout at 2023/10/23 2:32:24
Last Power Event............. Blackout at 2022/09/24 12:12:24 for 3 sec.
Last Power Event............. Blackout at 2021/07/14 12:12:24
Last Power Event............. Blackout at 2022/09/24 12:12:24 for 4 sec.
Last Power Event............. Blackout at 2022/09/24 12:12:24
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}