# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Last Power Event\.+\s(\w+)\s\S*\s(\d+\/\d+\/\d+\s+\d+\:\d+\d\:\d+)|(?:\s\S+\s)(\d+)\s(\S+)"
test_str = ("Last Power Event............. Blackout at 2023/10/23 2:32:24\n"
"Last Power Event............. Blackout at 2022/09/24 12:12:24 for 3 sec.\n"
"Last Power Event............. Blackout at 2021/07/14 12:12:24\n"
" Last Power Event............. Blackout at 2022/09/24 12:12:24 for 4 sec.\n"
" Last Power Event............. Blackout at 2022/09/24 12:12:24\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.