$re = '/Last Power Event\.+\s(\w+)\s\S*\s(\d+\/\d+\/\d+\s+\d+\:\d+\d\:\d+)|(?:\s\S+\s)(\d+)\s(\S+)/m';
$str = 'Last Power Event............. Blackout at 2023/10/23 2:32:24
Last Power Event............. Blackout at 2022/09/24 12:12:24 for 3 sec.
Last Power Event............. Blackout at 2021/07/14 12:12:24
Last Power Event............. Blackout at 2022/09/24 12:12:24 for 4 sec.
Last Power Event............. Blackout at 2022/09/24 12:12:24
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);