const regex = /Last Power Event\.+\s(\w+)\s\S*\s(\d+\/\d+\/\d+\s+\d+\:\d+\d\:\d+)|(?:\s\S+\s)(\d+)\s(\S+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Last Power Event\\.+\\s(\\w+)\\s\\S*\\s(\\d+\\\/\\d+\\\/\\d+\\s+\\d+\\:\\d+\\d\\:\\d+)|(?:\\s\\S+\\s)(\\d+)\\s(\\S+)', 'mg')
const str = `Last Power Event............. Blackout at 2023/10/23 2:32:24
Last Power Event............. Blackout at 2022/09/24 12:12:24 for 3 sec.
Last Power Event............. Blackout at 2021/07/14 12:12:24
Last Power Event............. Blackout at 2022/09/24 12:12:24 for 4 sec.
Last Power Event............. Blackout at 2022/09/24 12:12:24
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}