using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/([a-zA-Z]{2})\/([a-zA-Z]{1,10})(\/.*$)";
string input = @"/it/xyz/test/param+1/param-2/1234/gfd4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}