$re = '/^\/([a-zA-Z]{2})\/([a-zA-Z]{1,10})(\/.*$)/m';
$str = '/it/xyz/test/param+1/param-2/1234/gfd4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);